War Lua Help

言語: JP EN DE FR
2010-06-21
New Items
320 users online
フォーラム » FFXI » Jobs » Warrior » war lua help
war lua help
 Asura.Starfishsky
Offline
サーバ: Asura
Game: FFXI
user: starfish
Posts: 60
By Asura.Starfishsky 2017-02-21 05:07:14  
hello, if someone can kindly help me with this war.lua file
http://pastebin.com/LMpR8hEw

I took that lua file it was ready made, i am still new to this. i changed some of the stuff in it, it seems to be working except, when i change to PDT or MDT i don't know how to change back to normal mode except if i do a reload for gearswap.

i was wondering did i miss something in the script the binds, so far i found thse binds to be working :

F9 : switch accuracy modes
F10: Physical PDT
F11: Magical MDT
F12: seems to report the current status

thanks in advance!
 Bahamut.Ayasha
Offline
サーバ: Bahamut
Game: FFXI
user: Ayasha
Posts: 60
By Bahamut.Ayasha 2017-02-21 15:02:36  
When dealing with luas that use Mote's include files, the bindings are usually standardized unless explicitly defined in the job lua. They're listed in the function: " global_on_load() " in the Mote-Globals.lua file in ../GearSwap/libs directory. I'll post them here for you though.


These can also be used in macro with the following macro commands:


Of course, you could just use these in the chat box, too. Just replace '/console gs' with simply '//gs'.

Hope this is what you were looking for!
 Asura.Starfishsky
Offline
サーバ: Asura
Game: FFXI
user: starfish
Posts: 60
By Asura.Starfishsky 2017-02-23 05:45:06  
very helpfull , thank you !! i was starting to get doupts about this lua file, because the other lua file for my geo seemed to work a little different. good explanation !
Offline
Posts: 199
By Odinz 2017-03-04 01:19:45  
Hi.
I'm having trouble with WAR lua where it won't equip Ukko's Fury or King's Justice (I think because of the " ' ")

//gs equip sets.precast.WS["Ukko's Fury"] returns a command that says the set doesn't exist. Same for King's Justice.

However it does seem to be using the set inside game, but I'm fairly certain it isn't switching out all peices. (Which is why I wanted to start testing the sets equiping in the first place)

Has anyone else encountered this problem before and is there a workaround?
(I've also tried [\'Ukko\s Fury\'] and many variations of it.)
 Bahamut.Ayasha
Offline
サーバ: Bahamut
Game: FFXI
user: Ayasha
Posts: 60
By Bahamut.Ayasha 2017-03-04 02:12:35  
Try this. //gs equip precast.WS['Ukko\'s Fury'], or ["Ukko\'s Fury"] if you use double quotes. Same convention for King's Justice. '//gs equip' won't work if you use the 'sets' prefix, and its not needed for manually equipping sets.
Log in to post.