Spellcast GearCollector Not Finding Files?

言語: JP EN DE FR
2010-06-21
New Items
users online
フォーラム » Windower » Spellcast Scripting » Other » Spellcast GearCollector not finding files?
Spellcast GearCollector not finding files?
Offline
Posts: 39
By nomad2637 2013-02-19 07:55:40  
Okay, so a few days ago I made some gear sets in np++ and set everything up. I basically copy/pasted my dnc gear to my sch gear as far as format goes so there are no inconsistencies. The files are in the correct folder and right next to each other.

My problem is //gc dncgear works perfectly. //gc schgear doesn't work at all and I get an error: "File not found: C:\Program Files (x86)\Windower\plugins/spellcast/schgear.xml"

The first thing I noticed was after plugins the \ changes to /. It only does this for schgear.xml but not for anything else.

I've unloaded and reloaded sc and gc numerous times, keep getting same error. I don't know what would make gc use the wrong \/

Any ideas?

Edit: The code if you want it but it's exactly like my working dnc.
Code
<?xml version="1.0"?>
<spellcast>
<config />
<sets>
<group Name="Default">
 
<set name="sch">
<main>Chatoyant Staff</main>
<main>Arka IV</main>
<body>Heka's Kalasiris</body>
<head>Argute M.board</head>
<legs>Praeco Slacks</feet>
<waist>Korin Obi</waist>
<back>Twilight Cape</back>
<hands>Augur's Gloves</hands>
<ammo>Incantor Stone</ammo>
<sub>Verse Strap</sub>
<ring>Sirona's Ring</ring>
<ring>Prolix Ring</ring>
<ear>Gifted Earring</ear>
<ear>Loquac. Earring</ear>
<neck>Phalaina Locket</neck>
<neck>Stoicheion Medal</neck>
<back>Twilight Cape</back>
<ammo>Witchstone</ammo>
<ear>Aredan Earring</ear>
<head>Rubeus Bandeau</head>
<hands>Spolia Cuffs</hands>
<feet>Savant's Loafers +1</feet>
<ring>Icesoul Ring"</ring>
<ring>Icesoul Ring"</ring>
<ear>Moldavite Earring</ear>
<legs>Argute Pants +2</legs>
<waist>Argute Belt</waist>
<body>Savant's Gown +1</body>
<sub>Elementa Grip</sub>
<body>Rubeus Jacket</body>
<hands>Argute Bracers</hands>
<ring>Star Ring</ring>
<legs>Savant's Pants +2</legs>
<feet>Chelona Boots</feet>
<back>Grapevine Cape</back>
<neck>Eidolon Pendant</neck>
<waist>Austerity Belt</waist>
<legs>Nisse Slacks</legs>
<body>Chelona Blazer</body>
<back>Vita Cape</back>
<ammo>Clarus Stone</ammo>
<ear>Antivenom Earring</ear>
<waist>Austerity Belt</waist>
<head>Goliard Chapeau</head>
<sub>Ariesian Grip</sub>
<ear>Relaxing Earring</ear>
<sub>Macero Grip</sub>
<body>Anhur Robe</body>
<legs>Scholar's Pants</legs>
<feet>Literae Sabots</feet>
<head>Svnt. Bonnet +1</head>
<sub>Fulcio Grip</sub>
<neck>Colossus's Torque</neck>
<ring>Sheltered Ring</ring>
<feet>Chelona Boots</feet>
</set>
 
</group>
</sets>
<variables />
<rules />
</spellcast>
 Bismarck.Snprphnx
Offline
サーバ: Bismarck
Game: FFXI
user: Snprphnx
Posts: 2449
By Bismarck.Snprphnx 2013-02-19 08:13:21  
Dumb question, but I ask because I seem to always forget to do this. Did you save it in the XML format (from the format drop box in the save file menu), and not just type in .xml at the end of the file name. Otherwise, it's trying to save it as schgear.xml.txt
 Fairy.Miaa
Offline
サーバ: Fairy
Game: FFXI
user: nomad2637
Posts: 37
By Fairy.Miaa 2013-02-19 08:17:35  
Yup it's xml format with the pretty colors and everything.

I think the error lies within spellcast trying to find it in:

C:\Program Files (x86)\Windower\plugins/spellcast/schgear.xml

instead of:

C:\Program Files (x86)\Windower\plugins\spellcast\schgear.xml


But I haven't the slightest clue as to why its doing it this for that specific file (I've tried moving it to other folders, making copies etc.).
 Bismarck.Snprphnx
Offline
サーバ: Bismarck
Game: FFXI
user: Snprphnx
Posts: 2449
By Bismarck.Snprphnx 2013-02-19 08:20:53  
Try restarting your game, with all the stuff saved properly. I was back g a weird issue with gc as well. The file and formats were all correct, but it start running and stop 3 seconds later, saying it was complete.
 Fairy.Miaa
Offline
サーバ: Fairy
Game: FFXI
user: nomad2637
Posts: 37
By Fairy.Miaa 2013-02-19 08:22:44  
Have restarted game every time due to user protection settings (making a change in windower files disconnects ffxi when the notification appears). :\ lol
 Bismarck.Snprphnx
Offline
サーバ: Bismarck
Game: FFXI
user: Snprphnx
Posts: 2449
By Bismarck.Snprphnx 2013-02-19 08:24:55  
No idea then. You can try posting your question on the windower forums as well
 Fairy.Miaa
Offline
サーバ: Fairy
Game: FFXI
user: nomad2637
Posts: 37
By Fairy.Miaa 2013-02-19 08:43:11  
I'll try posting there. Hijacking your thread there since it won't let me make my own :( Sorry! haha

Edit: Well I guess it's not yours but saw your questions in it haha.

And also please if anyone knows why spellcast/gearcollector is trying to locate something using the wrong slash (/ instead of \) please fill me in. >.<
 Cerberus.Bikpik
Offline
サーバ: Cerberus
Game: FFXI
user: Bikpik
Posts: 47
By Cerberus.Bikpik 2013-02-19 09:15:14  
I think I remember the windower team not recommending having your windower folder in the program files directory, that may be it. Also, if you just name it Sch it should pick it up automatically
 Fairy.Miaa
Offline
サーバ: Fairy
Game: FFXI
user: nomad2637
Posts: 37
By Fairy.Miaa 2013-02-19 09:40:16  
I'll try putting it in C then. Tried various names but going to try deleting it, making a direct copy of another and then refilling it. Slightly different way than before.

edit:

Now I just get "File not found: C:\Windower\plugins/spellcast/sch.xml

again with the \ / *goes crazy*
 Fairy.Miaa
Offline
サーバ: Fairy
Game: FFXI
user: nomad2637
Posts: 37
By Fairy.Miaa 2013-02-19 09:53:47  
FINALLY!! After moving it to C and using reload spellcast instead of unload and then load it finally mentioned an error on line 12 that I totally missed...

It's working now.

Future reference. legs =\= feet. Not sure why it was trying to load form a different location though, but it's working now so I don't care. Thanks for all the help and ideas though. /blush
 Bismarck.Snprphnx
Offline
サーバ: Bismarck
Game: FFXI
user: Snprphnx
Posts: 2449
By Bismarck.Snprphnx 2013-02-19 10:16:46  
I didn't use specific gear type in mine. I just did everything with <item></item>. Glad it's working for you now
 Bismarck.Snprphnx
Offline
サーバ: Bismarck
Game: FFXI
user: Snprphnx
Posts: 2449
By Bismarck.Snprphnx 2013-02-19 10:20:27  
Also, your lines 44 and 45 have Icesoul Ring", need to remove that "
Log in to post.